Networks

Contents
Introduction
Example of protocol
IP
Portions
Binary representation
Subnet Mask
Classful Addressing
Types of IP addresses
Network Address
Broadcast Address
Host Address
CIDR Notation
Private IP Address
Subnetting Networks
List of TCP and UDP ports
Related Articles

Introduction

This page will help you navigate through articles about computer networks.

A network is a group of computers or other devices connected by wires or radio waves.

A host is a single device on a network.

The host can be accessed over the network.

A host can send requests to one or more hosts on the network.

A special term has been coined for contacting yourself over the network - contacting localhost

The basis of data exchange over the network is the transmission of electrical impulses. They can be converted to numbers. For example, take a high voltage for 1 and a low voltage for 0.

You can agree on which sets of ones and zeros you need to send for a successful exchange of information.

This will be called a protocol. There can be many protons and they can be embedded with each other. Examples of TCP, IP, UPD

Example of protocol

In this section, you can see my attempt to explain what protocols are to those who have no way of imagining them.

Let's have hosts A and B.

They agreed that to start the work, one should send the other.

11110000

get back

11110001

Before each message with data must be attributed before special counterwhich is first equal

10101010

And with each new message increase counter 1

In front of real data, you should always insert

00000000

Which are not yet in use.

Upon successful receipt, only the increased counter

When all data should be sent

00001111

Data can be transmitted at 8 bits per message.

Example of data exchange on this protocol

Suppose A wants to send B the following data:

1111111100000000

Since data is 16 bits, it needs to be broken down into two messages of 8 bits.

A → B: And sends. 11110000 Waiting back 11110001.

B receives an offer to exchange data, he is ready to receive and sends back 11110001

A receives a ready-to-receive signal from B and sends real data to 11111111. 1010101000000000

B gets B. 101010100000000011111111 and send it back. 10101011

A receives a data acceptance confirmation from B and sends a second piece of data. 101011000000000000000000

B gets B. 101011000000000000000000 and backs up. 10101101

A receives a confirmation of receiving the second piece of data and sends a message about the end of the data exchange. 00001111

B understands that the data has run out and starts processing it.

This example simply shows how protocols work, and in reality they are far more complex. You need to include a check. Package delivery, line checks, and more.

One protocol can be embedded in another.

Let’s say that in our example there are new rules called P1 and P2.

P1: If the data is not available

00000000

And

00000001

The data will not be 8 bits but 16 and in front of them there will be another 8 bits of information in which it is encrypted which program should process them.

P2: If not

00000000

Comes.

10000000

The data will be 32 bits without any other changes.

Obviously, P1 and P2 need to be processed differently. Both are based on our original protocol.

This example is too primitive, but one can imagine that P1 and P2 are new protocols only at a higher level.

IP

IP is the third layer protocol in the OSI model.

Example IP address 8.8.8. 8.

It divides the dots into four parts - an octet of 8 bits. Each octet can range from 0 to 255.

203.0.113.10/24

203.0.113 This is called the Network Portion.

.10 - This is Host Portion.

/24 Subnet Mask or simply netmask is a subnet mask.

With help. mask You can increase the size of the Host Portion using the Network Portion.

Without a mask, IP is not self-sufficient.example)

Binary representation
203 0 113 10
11001011 00000000 01110001 00001010
8 bits 8 bits 8 bits 8 bits

It was used until 1995. Classful Addressing

After 1995, Classless Addressing

Subnet Mask

In our first example, 24 bits are allocated for the network part of the address and 8 bits for hosts (hosts, also use the term nodes). Figure it out. How this division occurs can be studied Subnet Mask (or just netmask) is a subnet mask.

IP address and mask 255.255.255. 0
IP decimal 203 0 113 10
IP binary 11001011 00000000 01110001 00001010
Binary mask 11111111 11111111 11111111 00000000
Decimal mask 255 255 255 0

The mask is also broken into octets. In the table conveniently located binary IP Address and binary mask.

If the address bit is above 0 mask, it corresponds to the Host Portion.

If the address bit is above 1 mask, it is Network Portion.

The smaller the mask, the more unique hosts can be on the network.

In a large local network, you don’t want to spend 24 bits on the network and leave only 8 bits on the hosts.

Let me remind you that 8 bits is only 256 unique variants of which the first .0 is reserved for address of the network itself Network Address ) and the last .255 is reserved for the broadcast address ( Broadcast Address ), which you will learn about below, so there are only 254 unique IPs for hosts. ? Host Address ).

To increase the number of unique addresses for hosts need a different mask. For example,

255.0.0 mask. 0
11111111 . 00000000 . 00000000 . 00000000
255 . 0 . 0 . 0

In the mask 255.0.0.0 it is the opposite: 8 bits for the network part and 24 bits for the host

Example of IP address with this mask

IP and 255.0.0 mask. 0
IP decimal 10 . 0 . 0 . 10
IP binary 00001010 . 00000000 . 00000000 . 00001010
Binary mask 11111111 . 00000000 . 00000000 . 00000000
Decimal mask 255 . 0 . 0 . 0

It is not necessary to distinguish between Host Portion and Network Portion at the octet boundary.

IP and mask 255.255.240.0
IP decimal 10 . 0 . 0 . 10
IP binary 00001010 . 00000000 . 00000000 . 00001010
Binary mask 11111111 . 11111111 . 11110000 . 00000000
Decimal mask 255 . 255 . 240 . 0

IP from the previous example 10.0.0.10 can be a host on the network with a mask 255.0.0.0 and a mask 255.255.240.0

Let's see where the difference is.

Consider two IP addresses: 10.0.15.10 and 10.0.16.10.

If the mask is 255.0.0. 0

IP and 255.0.0 mask. 0
10.0.15.10 dec 10 . 0 . 15 . 10
10.0.15.10 bin 00001010 . 00000000 . 00001111 . 00001010
10.0.16.10 dec 10 . 0 . 16 . 10
10.0.16.10 bin 00001010 . 00000000 . 00010000 . 00001010
Binary mask 11111111 . 00000000 . 00000000 . 00000000
Decimal mask 255 . 0 . 0 . 0

Network part addresses occupy only the first octet and are marked in bold, 10.0.15.10 and 10.0.16.10 are two neighboring hosts on the same subnet.

Consider the same addresses but with a mask of 255.255.240.0

IP and mask 255.255.240.0
10.0.15.10 dec 10 . 0 . 15 . 10
10.0.15.10 bin 00001010 . 00000000 . 00001111 . 00001010
10.0.16.10 dec 10 . 0 . 16 . 10
10.0.16.10 bin 00001010 . 00000000 . 00010000 . 00001010
Binary mask 11111111 . 11111111 . 11110000 . 00000000
Decimal mask 255 . 255 . 240 . 0

Notice the third octet. Especially on the binary record.

None of the positive bits of 10.0.15.10 hit the network. (no fatty units)

Thus, at 10.0.15.10, the host address remained the same, but the network part of the IP address grew noticeably.

At 10.0.16.10, the unit in the third octet hit the network part. From the host address there are only 1010 a It is not the same as 10.0.15. 10

Thus, now 10.0.16.10 and 10.0.15.10 are not neighboring hosts of the same subnet. hosts on different subnets.

Classful Addressing

If you’ve ever heard of Class A, Class B, C, D, or E IP, that’s the case. Older Class Addressing (Classful Addressing)

Class addressing
Class class IP address range
A 0.0.0.0 127.255.255.255
B 128.0.0.0 191.255.255.255
C 192.0.0.0 223.255.255.255
D 224.0.0.0 239.255.255.255
E 240.0.0.0 255.255.255.255

A, B, and C are called Unicasts. These are the addresses currently used on the public Internet (with the exception of n private addresses . Principle - one device communicates with one device

D is multicast. One device communicates with several devices. Not supported on the Internet, but supported in large private networks for broadcasting meetings, etc.

Class A: The first 8 bits are always the network part

Class B: The first 16 bits are always the network part

Class C: The first 24 bits are always the network part

Class D: All 32 bits are always the network part

Types of IP addresses

According to the value of Host Portion, addresses can be divided into three types.

Network Address

Network Address or Network Prefix is a unique identifier for a group of devices. Like, like, The street name is a unique identifier for all houses on this street, but is not unique to the street. house (if there is more than one house on the street)

All bits in the Host Portion are 0.

Example of a network address
255.255.255.0 dec 255 . 255 . 255 . 0
255.255.255.0 bin 11111111 . 11111111 . 11111111 . 00000000

Broadcast Address

Broadcast Address: An identifier that identifies all devices on the network.

Broadcast address all bits in Host Portion are 1

Example of a broadcast address
255.255.255.255 dec 255 . 255 . 255 . 255
255.255.255.255 bin 11111111 . 11111111 . 11111111 . 11111111

What is different I will explain on the example: the postman was instructed to take the letter to the office TopBicycle On the street Partner and gave instructions

Deliver to the company Company;Site;Type;Address TopBicycle;www.TopBicycle.ru;Partnerskaya Street

It's like a network ader. There may be many offices on the street. Where exactly to carry the letter Do not immediately understand - you need to specify the address of the house (in the case of a network - the host address).

The next day, the postman was instructed to carry the notification of repairs on the street to all houses and offices on the street Partner.

The alerts are the same for all companies.

Deliver to all recipients Company;Site;Type;Address URN.SU;https://www.urn.su;IT;Partnerskaya Street HeiHei.ru;https://heihei.ru;TravelPartnerskaya Street TopBicycle.ru;https://topbicycle.ru;BicyclesPartnerskaya Street Aviasales;https://aviasales.ru;Travel;Partners Street Booking.com;https://booking.com;Hotels;Partners Street Hotellook;https://Hotellook.com;Hotels;Partners Street Velodrive;https://velodrive.ru;Bicycles;Partners Street Xiaomi;https://mi-shop.com;Android;Partners Street Samsung;https://www.samsungstore.ru;Android;Partners Street ;https://.ru;Books;Partners Street GeekBrains;https://gb.ru;Education;Partners Street Netology;https://netology.ru;Education;Partners Street TestSetup.ru;https://TestSetup.ru.ru;Education;Partners Street Pluralsight;https://Pluralsight.com;Education;Partners Street SovcomInsurance;https://sovcomins.ru;Insurance;Partners Street Polis 812;https://polis812.ru;Insurance;Partners Street Vivo;https://ru.vivo.com/;Android;Partners Street Beget;https://beget.com;Hosting;Partners Street Reg.ru;https://Reg.ru.ru;Hosting;Partners Street OLDI;https://oldi.ru;Laptops;Partners Street

It's the equivalent of a broadcast address. If there were two offices on the street, you should carry letters both ways. If twenty, all twenty. You don't have to know who's in what house, so if he's walking down the street with letters, It is easy to enter all houses in order (not according to the list, but because they are located on the street).

Host Address

Host Address: An identifier that identifies a particular device on the network.

A host address can have any combination of bits in a Host Portion except two: only zeros and only one.

Only zeros are a network address, only a few are broadcast. Everything else is host addresses.

The network address in the decimal record may not end at 0

Consider 10.128.224.64 with 255.255.255 mask. 224.

Checking if the address is a network address means checking whether the Host Portion contains only units or not.

One IP address is not enough for this, you need to consider it together with the mask to understand what it is. Host Portion

Example of a network address
IP decimal 10 . 128 . 224 . 64
Decimal mask 255 . 255 . 255 . 224
IP binary 00001010 . 10000000 . 11100000 . 01000000
Binary mask 11111111 . 11111111 . 11111111 . 11100000

The network part is highlighted in bold, it is obvious that only zeros remain in the host part and this address is the network.

CIDR Notation

Consider the mask 255.255.255. 0

The first 24 bits are units. Do not write constantly 255.255.255

/24

Next format is first slash, then Network Portion length

For example:

203.0.113.10/24

Private

There are three ranges of addresses that are not used on the public Internet.

10.0.0.0/8
172.16.0.0/12
192.168.0.0/16

Private IP Address Range
Beginning The End Mask
10.0.0.0 10.255.255.255 /8
172.16.0.0 172.31.255.255 /12
192.168.0.0 192.168.255.255 /16

It is recommended to avoid using the address 169.254.0.0/16. APIPA

127.0.0.1 is reserved for Loopback Address

This means the address of your computer. You can tell me your home address.

In IPv6, it looks like ::1

Subnetting Networks

Consider the IP address. 10.0.0.0/8

10.0.0.0
255.0.0.0

Range of host addresses (not including ends):

10.0.0.0 - 10.255.255.255

N 00001010 00000000 00000000 00000000
B 00001010 11111111 11111111 11111111
M 11111111 00000000 00000000 00000000

RFC



HTTP







List of TCP and UDP ports
PortTCPUDPIANA statusDescriptionSCTP
0ReservedReservedOfficial
N/AN/AUnofficialIn programming APIs (not in communication between hosts), requests a system-allocated (dynamic) port
1YesAssignedOfficialTCP Port Service Multiplexer (TCPMUX). Historic. Both TCP and UDP have been assigned to TCPMUX by IANA, but by design only TCP is specified.
5AssignedAssignedOfficialRemote Job Entry was historically using socket 5 in its old socket form, while MIB PIM has identified it as TCP/5 and IANA has assigned both TCP and UDP 5 to it.
7YesYesOfficialEcho Protocol
9YesYesOfficialDiscard Protocol
NoYesUnofficialWake-on-LAN
11YesYesOfficialActive Users (systat service)
13YesYesOfficialDaytime Protocol
15YesNoUnofficialPreviously netstat service
17YesYesOfficialQuote of the Day (QOTD)
18YesYesOfficialMessage Send Protocol
19YesYesOfficialCharacter Generator Protocol (CHARGEN)
20YesAssignedOfficialFile Transfer Protocol (FTP) data transfer
21YesAssignedOfficialFile Transfer Protocol (FTP) control (command)
22YesAssignedOfficialSecure Shell (SSH),
23YesAssignedOfficialTelnet protocol—unencrypted text communications
25YesAssignedOfficialSimple Mail Transfer Protocol (SMTP), used for email routing between mail servers
37YesYesOfficialTime Protocol
42AssignedYesOfficialHost Name Server Protocol
43YesAssignedOfficialWHOIS protocol
47ReservedReservedOfficial
49YesYesOfficialTACACS Login Host protocol.
51ReservedReservedOfficialHistorically used for Interface Message Processor logical address management, entry has been removed by IANA on 2013-05-25
52AssignedAssignedOfficialXerox Network Systems (XNS) Time Protocol. Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP.
53YesYesOfficialDomain Name System (DNS)
54AssignedAssignedOfficialXerox Network Systems (XNS) Clearinghouse (Name Server). Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP.
56AssignedAssignedOfficialXerox Network Systems (XNS) Authentication Protocol. Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP.
58AssignedAssignedOfficialXerox Network Systems (XNS) Mail. Despite this port being assigned by IANA, the service is meant to work on SPP (ancestor of IPX/SPX), instead of TCP/IP.
61ReservedReservedOfficialHistorically assigned to the NIFTP-Based Mail protocol,
67AssignedYesOfficialBootstrap Protocol (BOOTP) server; also used by Dynamic Host Configuration Protocol (DHCP)
68AssignedYesOfficialBootstrap Protocol (BOOTP) client; also used by Dynamic Host Configuration Protocol (DHCP)
69AssignedYesOfficialTrivial File Transfer Protocol (TFTP)
70YesAssignedOfficialGopher protocol
71–74YesYesOfficialNETRJS protocol
79YesAssignedOfficialFinger protocol
80YesAssignedOfficialHypertext Transfer Protocol (HTTP)
NoYesUnofficialQUIC, a transport protocol over UDP (still in draft as of April 2020), using stream multiplexing, encryption by default with TLS, and currently supporting HTTP/2. QUIC has been renamed to HTTP/3, which is currently an Internet Draft.
81YesUnofficialTorPark onion routing
82YesUnofficialTorPark control
83YesAssignedOfficialMIT ML Device, networking file system
88YesAssignedOfficialKerberos authentication system
90YesYesUnofficialPointCast (dotcom)
95YesAssignedOfficialSUPDUP, terminal-independent remote login
101YesAssignedOfficialNIC host name
102YesAssignedOfficialISO Transport Service Access Point (TSAP) Class 0 protocol;
104YesYesOfficialDigital Imaging and Communications in Medicine (DICOM; also port 11112)
105YesYesOfficialCCSO Nameserver
107YesYesOfficialRemote User Telnet Service (RTelnet)
108YesYesOfficialIBM Systems Network Architecture (SNA) gateway access server
109YesAssignedOfficialPost Office Protocol, version 2 (POP2)
110YesAssignedOfficialPost Office Protocol, version 3 (POP3)
111YesYesOfficialOpen Network Computing Remote Procedure Call (ONC RPC, sometimes referred to as Sun RPC)
113YesNoOfficialIdent, authentication service/identification protocol, used by IRC servers to identify users
YesAssignedOfficialAuthentication Service (auth), the predecessor to identification protocol. Used to determine a user's identity of a particular TCP connection.
115YesAssignedOfficialSimple File Transfer Protocol
117YesYesOfficialUUCP Mapping Project (path service)
118YesYesOfficialStructured Query Language (SQL) Services
119YesAssignedOfficialNetwork News Transfer Protocol (NNTP),
123AssignedYesOfficialNetwork Time Protocol (NTP), used for time synchronization
126YesYesOfficialFormerly Unisys Unitary Login, renamed by Unisys to NXEdit. Used by Unisys Programmer's Workbench for Clearpath MCP, an IDE for Unisys MCP software development
135YesYesOfficialDCE endpoint resolution
YesYesOfficialMicrosoft EPMAP (End Point Mapper), also known as DCE/RPC Locator service, used to remotely manage services including DHCP server, DNS server and WINS. Also used by DCOM
137YesYesOfficialNetBIOS Name Service, used for name registration and resolution
138AssignedYesOfficialNetBIOS Datagram Service
139YesAssignedOfficialNetBIOS Session Service
143YesAssignedOfficialInternet Message Access Protocol (IMAP),
152YesYesOfficialBackground File Transfer Program (BFTP)
153YesYesOfficialSimple Gateway Monitoring Protocol (SGMP), a protocol for remote inspection and alteration of gateway management information
156YesYesOfficialStructured Query Language (SQL) Service
158YesYesOfficialDistributed Mail System Protocol (DMSP, sometimes referred to as Pcmail)
161AssignedYesOfficialSimple Network Management Protocol (SNMP)
162YesYesOfficialSimple Network Management Protocol Trap (SNMPTRAP)
170YesYesOfficialNetwork PostScript print server
177YesYesOfficialX Display Manager Control Protocol (XDMCP), used for remote logins to an X Display Manager server
179YesAssignedOfficialBorder Gateway Protocol (BGP),
194YesYesOfficialInternet Relay Chat (IRC)
199YesYesOfficialSNMP Unix Multiplexer (SMUX)
201YesYesOfficialAppleTalk Routing Maintenance
209YesAssignedOfficialQuick Mail Transfer Protocol
210YesYesOfficialANSI Z39.50
213YesYesOfficialInternetwork Packet Exchange (IPX)
218YesYesOfficialMessage posting protocol (MPP)
220YesYesOfficialInternet Message Access Protocol (IMAP), version 3
225–241ReservedReservedOfficial
249–255ReservedReservedOfficial
259YesYesOfficialEfficient Short Remote Operations (ESRO)
262YesYesOfficialArcisdms
264YesYesOfficialBorder Gateway Multicast Protocol (BGMP)
280YesYesOfficialhttp-mgmt
300YesUnofficialThinLinc Web Access
308YesOfficialNovastor Online Backup
311YesAssignedOfficialMac OS X Server Admin)
318YesYesOfficialPKIX Time Stamp Protocol (TSP)
319YesOfficialPrecision Time Protocol (PTP) event messages
320YesOfficialPrecision Time Protocol (PTP) general messages
350YesYesOfficialMapping of Airline Traffic over Internet Protocol (MATIP) type A
351YesYesOfficialMATIP type B
356YesYesOfficialcloanto-net-1 (used by Cloanto Amiga Explorer and VMs)
366YesYesOfficialOn-Demand Mail Relay (ODMR)
369YesYesOfficialRpc2portmap
370YesYesOfficialcodaauth2, Coda authentication server
YesOfficialsecurecast1, outgoing packets to NAI's SecureCast serversAs of 2000
371YesYesOfficialClearCase albd
383YesYesOfficialHP data alarm manager
384YesYesOfficialA Remote Network Server System
387YesYesOfficialAURP (AppleTalk Update-based Routing Protocol)
388YesAssignedOfficialUnidata LDM near real-time data distribution protocol
389YesAssignedOfficialLightweight Directory Access Protocol (LDAP)
399YesYesOfficialDigital Equipment Corporation DECnet+ (Phase V) over TCP/IP (RFC1859)
401YesYesOfficialUninterruptible power supply (UPS)
427YesYesOfficialService Location Protocol (SLP)
433YesYesOfficialNNSP, part of Network News Transfer Protocol
434YesYesOfficialMobile IP Agent (RFC 5944)
443YesAssignedOfficialHypertext Transfer Protocol over TLS/SSL (HTTPS)
NoYesUnofficialQuick UDP Internet Connections (QUIC), a transport protocol over UDP (still in draft as of July 2018), using stream multiplexing, encryption by default with TLS, and currently supporting HTTP/2.
444YesYesOfficialSimple Network Paging Protocol (SNPP), RFC 1568
445YesYesOfficialMicrosoft-DS (Directory Services) Active Directory, Windows shares
YesAssignedOfficialMicrosoft-DS (Directory Services) SMB file sharing
464YesYesOfficialKerberos Change/Set password
465YesNoOfficialURL Rendezvous Directory for SSM (Cisco protocol)
YesNoOfficialAuthenticated SMTP
475YesYesOfficialtcpnethaspsrv, Aladdin Knowledge Systems Hasp services
491YesUnofficialGO-Global remote access and application publishing software
497YesYesOfficialRetrospect
500AssignedYesOfficialInternet Security Association and Key Management Protocol (ISAKMP) / Internet Key Exchange (IKE)
502YesYesOfficialModbus Protocol
504YesYesOfficialCitadel, multiservice protocol for dedicated clients for the Citadel groupware system
510YesYesOfficialFirstClass Protocol (FCP), used by FirstClass client/server groupware system
512YesOfficialRexec, Remote Process Execution
YesOfficialcomsat, together with biff
513YesOfficialrlogin
YesOfficialWho
514YesUnofficialRemote Shell, used to execute non-interactive commands on a remote system (Remote Shell, rsh, remsh)
NoYesOfficialSyslog, used for system logging
515YesAssignedOfficialLine Printer Daemon (LPD), print service
517YesOfficialTalk
518YesOfficialNTalk
520YesOfficialefs, extended file name server
YesOfficialRouting Information Protocol (RIP)
521YesOfficialRouting Information Protocol Next Generation (RIPng)
524YesYesOfficialNetWare Core Protocol (NCP) is used for a variety things such as access to primary NetWare server resources, Time Synchronization, etc.
525YesOfficialTimed, Timeserver
530YesYesOfficialRemote procedure call (RPC)
532YesAssignedOfficialnetnews
533YesOfficialnetwall, For Emergency Broadcasts
540YesOfficialUnix-to-Unix Copy Protocol (UUCP)
542YesYesOfficialcommerce (Commerce Applications)
543YesOfficialklogin, Kerberos login
544YesOfficialkshell, Kerberos Remote shell
546YesYesOfficialDHCPv6 client
547YesYesOfficialDHCPv6 server
548YesAssignedOfficialApple Filing Protocol (AFP) over TCP
550YesYesOfficialnew-rwho, new-who
554YesYesOfficialReal Time Streaming Protocol (RTSP)
556YesOfficialRemotefs, RFS, rfs_server
560YesOfficialrmonitor, Remote Monitor
561YesOfficialmonitor
563YesYesOfficialNNTP over TLS/SSL (NNTPS)
564YesUnofficial9P (Plan 9)
585Port 993?UnofficialLegacy use of Internet Message Access Protocol over TLS/SSL (IMAPS), now in use at port 993.
587YesAssignedOfficialemail message submission (SMTP)
591YesOfficialFileMaker 6.0 (and later) Web Sharing (HTTP Alternate, also see port 80)
593YesYesOfficialHTTP RPC Ep Map, Remote procedure call over Hypertext Transfer Protocol, often used by Distributed Component Object Model services and Microsoft Exchange Server
601YesOfficialReliable Syslog Service — used for system logging
604YesOfficialTUNNEL profile, a protocol for BEEP peers to form an application layer tunnel
623YesOfficialASF Remote Management and Control Protocol (ASF-RMCP) & IPMI Remote Management Protocol
625YesNoUnofficialOpen Directory Proxy (ODProxy)
631YesYesOfficialInternet Printing Protocol (IPP)
YesYesUnofficialCommon Unix Printing System (CUPS) administration console (extension to IPP)
635YesYesOfficialRLZ DBase
636YesAssignedOfficialLightweight Directory Access Protocol over TLS/SSL (LDAPS)
639YesYesOfficialMSDP, Multicast Source Discovery Protocol
641YesYesOfficialSupportSoft Nexus Remote Command (control/listening), a proxy gateway connecting remote control traffic
643YesYesOfficialSANity
646YesYesOfficialLabel Distribution Protocol (LDP), a routing protocol used in MPLS networks
647YesOfficialDHCP Failover protocol
648YesOfficialRegistry Registrar Protocol (RRP)
651YesYesOfficialIEEE-MMS
653YesYesOfficialSupportSoft Nexus Remote Command (data), a proxy gateway connecting remote control traffic
654YesOfficialMedia Management System (MMS) Media Management Protocol (MMP)
655YesYesOfficialTinc VPN daemon
657YesYesOfficialIBM RMC (Remote monitoring and Control) protocol, used by System p5 AIX Integrated Virtualization Manager (IVM) and Hardware Management Console to connect managed logical partitions (LPAR) to enable dynamic partition reconfiguration
660YesAssignedOfficialMac OS X Server administration,
666YesYesOfficialDoom, first online first-person shooter
YesUnofficialairserv-ng, aircrack-ng's server for remote-controlling wireless devices
674YesOfficialApplication Configuration Access Protocol (ACAP)
688YesYesOfficialREALM-RUSD (ApplianceWare Server Appliance Management Protocol)
690YesYesOfficialVelneo Application Transfer Protocol (VATP)
691YesOfficialMS Exchange Routing
694YesYesOfficialLinux-HA high-availability heartbeat
695YesOfficialIEEE Media Management System over SSL (IEEE-MMS-SSL)
698YesOfficialOptimized Link State Routing (OLSR)
700YesOfficialExtensible Provisioning Protocol (EPP), a protocol for communication between domain name registries and registrars (RFC 5734)
701YesOfficialLink Management Protocol (LMP), a protocol that runs between a pair of nodes and is used to manage traffic engineering (TE) links
702YesOfficialIRIS (RFC 3983)
706YesOfficialSecure Internet Live Conferencing (SILC)
711YesOfficialCisco Tag Distribution Protocol
712YesOfficialTopology Broadcast based on Reverse-Path Forwarding routing protocol (TBRPF; RFC 3684)
749YesYesOfficialKerberos (protocol) administration
750YesOfficialkerberos-iv, Kerberos version IV
751YesYesUnofficialkerberos_master, Kerberos authentication
752YesUnofficialpasswd_server, Kerberos password (kpasswd) server
753YesYesOfficialReverse Routing Header (RRH)
YesUnofficialuserreg_server, Kerberos userreg server
754YesYesOfficialtell send
YesUnofficialkrb5_prop, Kerberos v5 slave propagation
760YesYesUnofficialkrbupdate , Kerberos registration
782YesUnofficialConserver serial-console management server
783YesUnofficialSpamAssassin spamd daemon
800YesYesOfficialmdbs-daemon
802YesYesOfficialMODBUS/TCP Security
808YesUnofficialMicrosoft Net.TCP Port Sharing Service
829YesAssignedOfficialCertificate Management Protocol
830YesYesOfficialNETCONF over SSH
831YesYesOfficialNETCONF over BEEP
832YesYesOfficialNETCONF for SOAP over HTTPS
833YesYesOfficialNETCONF for SOAP over BEEP
843YesUnofficialAdobe Flash
847YesOfficialDHCP Failover protocol
848YesYesOfficialGroup Domain Of Interpretation (GDOI) protocol
853YesYesOfficialDNS over TLS (RFC 7858)
860YesOfficialiSCSI (RFC 3720)
861YesYesOfficialOWAMP control (RFC 4656)
862YesYesOfficialTWAMP control (RFC 5357)
873YesOfficialrsync file synchronization protocol
888YesUnofficialcddbp, CD DataBase (CDDB) protocol (CDDBP)
YesUnofficialIBM Endpoint Manager Remote Control
897YesYesUnofficialBrocade SMI-S RPC
898YesYesUnofficialBrocade SMI-S RPC SSL
902YesYesUnofficialVMware ESXi
903YesUnofficialVMware ESXi
953YesReservedOfficialBIND remote name daemon control (RNDC)
981YesUnofficialRemote HTTPS management for firewall devices running embedded Check Point VPN-1 software
987YesUnofficialMicrosoft Remote Web Workplace, a feature of Windows Small Business Server
989YesYesOfficialFTPS Protocol (data), FTP over TLS/SSL
990YesYesOfficialFTPS Protocol (control), FTP over TLS/SSL
991YesYesOfficialNetnews Administration System (NAS)
992YesYesOfficialTelnet protocol over TLS/SSL
993YesAssignedOfficialInternet Message Access Protocol over TLS/SSL (IMAPS)
994ReservedReservedOfficial
MaybeMaybeUnofficialInternet Relay Chat over TLS/SSL (IRCS). Previously assigned, but not used in common practice.
995YesYesOfficialPost Office Protocol 3 over TLS/SSL (POP3S)
1010YesUnofficialThinLinc web-based administration interface
1011–1020ReservedReservedOfficial
1023ReservedReservedOfficial
YesYesUnofficialz/OS Network File System (NFS) (potentially ports 991–1023)

Related Articles:

Article author: Andrei Olegovich

Related articles
SSH
DNS
PuTTY
Telnet
PSTools
Firefox
FreeSSHD
Networks
SSH tunnel HowTo
Port Forwarding HowTo

Search this site

Subscribe to Telegram channel @aofeed to follow new articles and updates to old ones

Go to channel

@aofeed

Ask a question in the Telegram group

@aofeedchat

Contacts and cooperation:
I recommend our hosting beget.ru
Write to info@aredel.com if you:
1. Want to write an article for our site or translate an article into your native language.
2. Want to place thematically relevant ads on the site.
3. Ads on my site pass maximum censorship. If you see an ad block unsuitable for school-age children, shocking or misleading - please contact us by e-mail
4. Found a mistake, inaccuracy, bug, etc. on the site. ... .......
5. Articles can be shared on social media by clicking a network icon: